PDA

View Full Version : HELP! My DS is....


Starbom
08-15-2012, 10:33 PM
Story: I was playing my DS last night, my power went to red, and so I decided to plug the charger in by the microwave. Somebody had moved it onto the counter that was wet from dishes. I went to pick up my DS to do the Royal Unova daily event on PKMN white and it was soaked. I dried it off with a cloth, turned it on and it worked fine.

More water was dripping out so I shut down, took out my GBA and DS games, blew all the water out then turned it on again. This time I got a blank black screen. I wiped it down and cleaned it again. Got another black screen.

After the 3rd time, it worked, I went to the boat, battled a youngster, then went to battle a clerk male's Ariados when I got Magmortar to use flamethrower.

Now when I clicked it, it brought me to the screen as if i went to my party, clicked magmortar and pressed "Check moves". With this going down I cant attack. I thought it may of just been the bottom right hand attack, so I tried thunderbolt (Which I used to defeat the youngster) and I got the same "Check moves" interface. Shut down, cleaned DS again, and tried again. Still not working.

Help please? I dont have money for a new DS, and Im already saving to replace my YLOD'd PS3.


TL;DR: DS is wet, I dried it and its still not working at 100%. Need help to repair it.

Digital
08-15-2012, 10:40 PM
I would leave the DS in a dry room so that the water inside the DS is slowly evaporated. If that doesn't work, either leave it in a bowl of dry rice or out on the table open and facing down.

Hopefully if you dry the DS, you may evaporate some of the water and it may work. If you want to heat it up quicker, use a Hairdryer or something like that.

Neku Sakuraba
08-15-2012, 11:35 PM
Hmm...I've had this problem before, my friend. Though, usually, I got to it fast enough to dry it off and not affect anything. Though, this has happened to my phone, and I left it in a bag of rice to evaporate the water. So, listen to what Digital says. If that doesn't work, then send it in for repairs and see what happens.

Obliveon
08-16-2012, 12:25 AM
It may be that the battery is wet or the screen components. At least yours worked for awhile. Mine never did again [but it was really beat up and was almost completely submerged]. Follow their steps^ , and if it doesn't work I'd try replacing the battery or sending it in for repairs.

Starbom
08-16-2012, 01:12 AM
It seems dry. It turns on for a sec then auto shuts down. It was working perfectly til I put Animal Crossing in, but wont turn on now. I should try that rice thing though.
Ive been playing Animal crossing every day since May 2006, I never let anyone move. Looks like thats changing --.

Edit: For the Rice thing, do I take all my games out for better suction ? Or leave in so rice doesnt get inside ds O_o

Digital
08-16-2012, 06:55 PM
I would keep the game in, or cover it up with some tape.

If it doesn't work, then take it to a repair place and see what they can do.

Starbom
08-16-2012, 07:15 PM
Keep stylus in too? It seems thats where like 90% of the water is.

Also what kind of repair place? Like EB games? O_o

Digital
08-16-2012, 07:33 PM
I would remove the Stylus, so that the rice can absorb the water.

I wouldn't know many repair places in America, since I'm from England.