PDA

View Full Version : My Wii isn't working, HELP!


SilverScizor
11-25-2008, 05:31 PM
When I tried to go on the nintendo channel it wouldn't come on so i tried turning it off by the button but it wouldn't, so i switched off the plug and switched it back on again and now it isn't coming on! There isn't even one of those red lights. Does anyone know how to fix it?

fatshine179
11-25-2008, 10:42 PM
When I tried to go on the nintendo channel it wouldn't come on so i tried turning it off by the button but it wouldn't, so i switched off the plug and switched it back on again and now it isn't coming on! There isn't even one of those red lights. Does anyone know how to fix it?

damn bro, idk..it kinda sounds like the red ring of death from the Xbox.

MYSTRY MEW
11-25-2008, 10:53 PM
you unplugged it and plugged it back in right? all the cords?

Royal Pichu
11-26-2008, 04:20 AM
Hmm i have never heard of this happen before, try calling nintendo and see if they can help with your problem if not then hope you have waranty.

ThEcHaMpIoNoFsApPhIrE
11-27-2008, 03:22 AM
Hmm i have never heard of this happen before, try calling nintendo and see if they can help with your problem if not then hope you have waranty.
i had a problem today where i was having a never-ending battle on mariocart online. the timer went all the way to zero, but i was still playing, and nobody but my brother (same console) was playing, everyone disappeared, my theory was that we were hacked or something! lol

Royal Pichu
11-28-2008, 06:02 AM
i had a problem today where i was having a never-ending battle on mariocart online. the timer went all the way to zero, but i was still playing, and nobody but my brother (same console) was playing, everyone disappeared, my theory was that we were hacked or something! lol
It might just be wi-fi acting up. Sometimes that happenes to me where im last and theres like 2 laps left and suddenly the timer goes crazy and everyone dissapears and i get 1st placexD lol

Charbok
11-28-2008, 11:36 PM
Un-plug EVERYTHING out of the back of the Wii and plug it all back in.